ボツ写真のRAWファイルを自動削除(その2)

今回は実際のプログラムソースを解説していきます。
初めての方は、↓↓↓昨日の(その1)↓↓↓からご覧ください。

まずはとりあえず、なでしこをダウンロードして実行環境を整えましょう。
実行できる環境になれば、僕が作ったこのプログラムをダウンロードしてください。

そして、このプログラム(raw.nako)を『なでしこ』で読み込んでみます。
a0098145_2173183.jpg

実際のソースは↓こちら。

========================================
作業フォルダ=フォルダ選択。もし、作業フォルダ=空ならば終わる
RAW拡張子は「*.CR2」
「ファイル移動中・・・」を表示
「{作業フォルダ}{RAW拡張子}」の全ファイル列挙して反復
対象はそれ。母艦は対象
対象からファイル名抽出してRAWに代入
RAWを「.JPG」に拡張子変更してJPEGに代入
もし「{作業フォルダ}{JPEG}」が存在ならば
「{作業フォルダ}{JPEG}」から「{作業フォルダ}JPEG\{JPEG}」へファイル移動
違えば
対象をファイル削除
「作 業 終 了」を表示
終わる
========================================

2行目はCANONのカメラに合わせて【RAW拡張子は「*.CR2】としてますが、他機種の場合は
任意に変えてください。

で、このプログラムを実行すると昨日書いたようにボツ写真のRAWファイルが自動削除されます。
とりあえず試してみる前に、ちゃんとバックアップは取っておいて下さいね。
a0098145_2124553.jpg

日本語プログラムなので、だいたい何をやってるか理解して頂けるとは思いますが、
これを取っ掛かりにして(簡単な)プログラムの世界に足を突っ込んで行かれるのも良いかと(^^ゞ

EXE形式の実行ファイルを作って効率的に運用されるのもアリですし、いろいろ試してみてください。
質問があれば、何でもメールでお聞きください。(^^)/~
[PR]
by judd1229 | 2009-07-27 01:00 | tech
<< ゴーヤチャンプルはスピードが命! ボツ写真のRAWファイルを自動... >>